7.11. Что такое вложенные циклы?

Возможны случаи, когда внутри тела цикла необходимо повторять некоторую последовательность операторов, т. е. организовать внутренний цикл. Такая структура получила название цикла в цикле или вложенных циклов. Глубина вложения циклов (то есть количество вложенных друг в друга циклов) может быть различной.

При использовании такой структуры для экономии машинного времени необходимо выносить из внутреннего цикла во внешний все операторы, которые не зависят от параметра внутреннего цикла.
Пример вложенных циклов для

Вычислить сумму элементов заданной матрицы А(5,3).

Матрица А
 
нц для i от 1 до 5
  нц для j от 1 до 3
    S:=S+A[i,j]
  кц
кц


Пример вложенных циклов пока

Вычислить произведение тех элементов заданной матрицы A(10,10), которые расположены на пересечении четных строк и четных столбцов.

i:=2; P:=1
нц пока i <= 10
  j:=2
  нц пока j <= 10
    P:=P*A[i,j]
    j:=j+2
  кц
  i:=i+2
кц

Другие записи

10.06.2016. 7.4. В какой форме записываются алгоритмы? 7.5. Что такое словесный способ записи алгоритмов? 7.6. Что такое графический способ записи алгоритмов?
7.4. В какой форме записываются алгоритмы? На практике наиболее распространены следующие формы представления алгоритмов:   словесная (записи на естественном языке); графическая (изображения…
10.06.2016. 7.7. Что такое псевдокод? 7.8. Как записываются алгоритмы на школьном алгоритмическом языке?
7.7. Что такое псевдокод? Псевдокод представляет собой систему обозначений и правил, предназначенную для единообразной записи алгоритмов. Он занимает промежуточное место между естественным…
10.06.2016. 7.9. Что такое базовые алгоритмические структуры?
Алгоритмы можно представлять как некоторые структуры, состоящие из отдельных базовых (т.е. основных) элементов. Естественно, что при таком подходе к алгоритмам изучение основных принципов их конструирования…
10.06.2016. 7.10. Какие циклы называют итерационными?
Особенностью итерационного цикла является то,что число повторений операторов тела цикла заранее неизвестно. Для его организации используется цикл типа пока. Выход из итерационного цикла осуществляется…
10.06.2016. 7.23. Ответы к упражнениям
7.1. а) (x+y)/(x-1/2)-(x-z)/(x*y); б) (1+z)*(x+y/z)/(a-1/(1+x*x)); в) x**(n*(m+2)) + x**(n**m); г) (a+b)**n/(1+a/(a**m-b**(m-n))); д) (a[i]**(2*l) + b[j+1]**(2*k)) * (3**n-x*x*y)/(z-(d[i,j+1]+1)/(z+ …