7.7. Что такое псевдокод? 7.8. Как записываются алгоритмы на школьном алгоритмическом языке?

7.7. Что такое псевдокод?

Псевдокод представляет собой систему обозначений и правил, предназначенную для единообразной записи алгоритмов.

Он занимает промежуточное место между естественным и формальным языками.

С одной стороны, он близок к обычному естественному языку, поэтому алгоритмы могут на нем записываться и читаться как обычный текст. С другой строны, в псевдокоде используются некоторые формальные конструкции и математическая символика, что приближает запись алгоритма к общепринятой математической записи.

В псевдокоде не приняты строгие синтаксические правила для записи команд, присущие формальным языкам, что облегчает запись алгоритма на стадии его проектирования и дает возможность использовать более широкий набор команд, рассчитанный на абстрактного исполнителя. Однако в псевдокоде обычно имеются некоторые конструкции, присущие формальным языкам, что облегчает переход от записи на псевдокоде к записи алгоритма на формальном языке. В частности, в псевдокоде, так же, как и в формальных языках, есть служебные слова, смысл которых определен раз и навсегда. Они выделяются в печатном тексте жирным шрифтом, а в рукописном тексте подчеркиваются. Единого или формального определения псевдокода не существует, поэтому возможны различные псевдокоды, отличающиеся набором служебных слов и основных (базовых) конструкций.

Примером псевдокода является школьный алгоритмический язык в русской нотации (школьный АЯ), описанный в учебнике А.Г. Кушниренко и др. "Основы информатики и вычислительной техники", 1991. Этот язык в дальнейшем мы будем называть просто "алгоритмический язык".

7.8. Как записываются алгоритмы на школьном алгоритмическом языке?
Основные служебные слова

алг (алгоритм) сим (символьный) дано для да
арг (аргумент) лит (литерный) надо от нет
рез (результат) лог (логический) если до при
нач (начало) таб(таблица) то знач выбор
кон (конец) нц (начало цикла) иначе и ввод
цел (целый) кц (конец цикла) все или вывод
вещ (вещественный) длин (длина) пока не утв

 

Общий вид алгоритма:
алг название алгоритма (аргументы и результаты)
дано условия применимости алгоритма
надо цель выполнения алгоритма
нач описание промежуточных величин
| последовательность команд (тело алгоритма)
кон

Часть алгоритма от слова алг до слова нач называется заголовком, а часть, заключенная между словами нач и кон - телом алгоритма.

В предложении алг после названия алгоритма в круглых скобках указываются характеристики (арг, рез) и тип значения (цел, вещ, сим, лит или лог) всех входных (аргументы) и выходных (результаты) переменных. При описании массивов (таблиц) используется служебное слово таб, дополненное граничными парами по каждому индексу элементов массива.

Примеры предложений алг:

  •  
    • алг Объем и площадь цилиндра (арг вещ R, H, рез вещ V, S)
    • алг Корни КвУр(арг вещ а, b, c, рез вещ x1, x2, рез лит t)
    • алг Исключить элемент(арг цел N, арг рез вещ таб А[1:N])
    • алг Диагональ(арг цел N, арг цел таб A[1:N,1:N], рез лит Otvet)

Предложения дано и надо не обязательны. В них рекомендуется записывать утверждения, описывающие состояние среды исполнителя алгоритма, например:

    1. алг Замена (арг лит Str1, Str2, арг рез лит Text)
    дано | длины подстрок Str1 и Str2 совпадают
    надо | всюду в строке Text подстрока Str1 заменена на Str2

    2. алг Число максимумов (арг цел N, арг вещ таб A[1:N], рез цел K)
    дано | N>0
    надо | К - число максимальных элементов в таблице А

    3. алг Сопротивление (арг вещ R1, R2, арг цел N, рез вещ R)
    дано | N>5, R1>0, R2>0
    надо | R - сопротивление схемы


Здесь в предложениях дано и надо после знака "|" записаны комментарии. Комментарии можно помещать в конце любой строки. Они не обрабатываются транслятором, но существенно облегчают понимание алгоритма. Команды школьного АЯ
Оператор присваивания. Служит для вычисления выражений и присваивания их значений переменным. Общий вид: А := В, где знак ":=" означает команду заменить прежнее значение переменной, стоящей в левой части, на вычисленное значение выражения, стоящего в правой части.

Например, a:=(b+c)*sin(Pi/4); i:=i+1.

Для ввода и вывода данных используют команды

  •  
    • ввод имена переменных
    • вывод имена переменных, выражения, тексты.

Для ветвления применяют команды если и выбор, для организации циклов - команды для и пока, описанные в разделе 7.9. Пример записи алгоритма на школьном АЯ
алг Сумма квадратов (арг цел n, рез цел S)
дано | n > 0
надо | S = 1*1 + 2*2 + 3*3 + ... + n*n
нач цел i
  ввод n; S:=0
  нц для i от 1 до n
    S:=S+i*i
  кц
  вывод "S = ", S
кон

Другие записи

10.06.2016. 7.4. В какой форме записываются алгоритмы? 7.5. Что такое словесный способ записи алгоритмов? 7.6. Что такое графический способ записи алгоритмов?
7.4. В какой форме записываются алгоритмы? На практике наиболее распространены следующие формы представления алгоритмов:   словесная (записи на естественном языке); графическая (изображения…
10.06.2016. 7.23. Ответы к упражнениям
7.1. а) (x+y)/(x-1/2)-(x-z)/(x*y); б) (1+z)*(x+y/z)/(a-1/(1+x*x)); в) x**(n*(m+2)) + x**(n**m); г) (a+b)**n/(1+a/(a**m-b**(m-n))); д) (a[i]**(2*l) + b[j+1]**(2*k)) * (3**n-x*x*y)/(z-(d[i,j+1]+1)/(z+ …