Пример 1.1. Простейший алгоритм, запрашивающий имя и затем приветствующий его обладателя.

Тест

Данные Результат
Имя = "Тимур" "Привет, Тимур!"

Школьный АЯ
алг Знакомство (арг лит Имя, резлит t) 
нач
  вывод "Как тебя зовут ?"
  ввод Имя
  t := "Привет, " + Имя + "!"   | "+" - операция сцепки
  вывод t
кон
 
Turbo Pascal

Program Hello;
Var Name: String;  {Описание переменной Name строкового типа}
BEGIN 
  Write('Как тебя зовут ? '); {Вывод на экран текста вопроса}
  ReadLn(Name); {Ввод c клавиатуры имени}
  WriteLn('Привет, ', Name, '!'); {Вывод на экран приветствия}
  ReadLn
END.
 
Здесь последний оператор ReadLn позволяет видеть на экране результаты

работы программы, пока не будет нажата клавиша <Enter>.
 
Результаты работы Pascal-программы

 
Как тебя зовут ? Тимур   <Enter>
Привет, Тимур ! 


QBasic
CLS
INPUT "Как тебя зовут ? ", Name$
PRINT "Привет, "; Name$; "!"
END

Другие записи

10.06.2016. Пример 1.2. Определить объём и площадь боковой поверхности цилиндра с заданными радиусом основания R и высотой H.
Тест Данные Результат R = 1 H = 1 V = 3.14 S = 6.28 Школьный АЯ алг Цилиндр (арг вещ R, H, рез вещ V, S) нач вещ Pi Pi := 3.14  V := Pi * R**2 * H  S := 2 *…
10.06.2016. Пример 1.3. Даны три точки на плоскости. Определить, какая из них ближе к началу координат.
Система тестов Номер теста Данные Результат xA yA xB yB xC yC Otvet 1 2 1 2 2 -1 3 "Это точка A" 2 2 2 2 1 -1 3 "Это точка B" 3 2 2 -1 3 2 1 "Это…
10.06.2016. Пример 1.4. Найти произведение цифр заданного целого четырехзначного числа.
Система тестов Номер теста Проверяемый  случай Число Результат 1 Число положительное 2314 P = 24 2 Число отрицательное -1245 P = 40 Школьный АЯ алг Произведение…
10.06.2016. Пример 1.5. Решить квадратное уравнение ax2 + bx + c = 0.
Система тестов Номер теста Проверяемый случай Коэффициенты Результаты a b c 1 d >0 1 1 -2 x1 = 1, x2 =  - 2 2 d=0 1 2 1 Корни равны:  x1 =  - 1, x2 =  - 1 3 d<0 2 1 2 Действительных…