Пример 1.3. Даны три точки на плоскости. Определить, какая из них ближе к началу координат.

Система тестов

Номер теста Данные Результат
xA yA xB yB xC yC Otvet
1 2 1 2 2 -1 3 "Это точка A"
2 2 2 2 1 -1 3 "Это точка B"
3 2 2 -1 3 2 1 "Это точка C"

Школьный АЯ
алг Точки(арг вещ xA,yA,xB,yB,xC,yC, рез лит Otvet)
нач вещ DistA,DistB,DistC
 
ввод xA,yA,xB,yB,xC,yC
  DistA := sqrt(xA**2 + yA**2)
  DistB := sqrt(xB**2 + yB**2)
  DistC := sqrt(xC**2 + yC**2)

  если (DistA < DistB) и (DistA < DistC)
  то Otvet := "Это точка А"
  иначе если
DistB < DistC
  то Otvet := "Это точка B"
  иначе Otvet := "Это точка C"
  все
  все
  вывод Otvet
кон
 
Turbo Pascal

Program Points;
  Uses Crt;
  Var xA, yA, xB, yB, xC, yC, DistA, DistB, DistC : Real;
BEGIN ClrScr;
 
WriteLn('Введите координаты точки А:');
  Write('x = '); ReadLn(xA); Write('y = '); ReadLn(yA);
  WriteLn('Введите координаты точки B:');
  Write('x = '); ReadLn(xB); Write('y = '); ReadLn(yB);
  WriteLn('Введите координаты точки C:');
  Write('x = '); ReadLn(xC); Write('y = '); ReadLn(yC);
 
  DistA := sqrt(sqr(xA) + sqr(yA));
  DistB := sqrt(sqr(xB) + sqr(yB));
  DistC := sqrt(sqr(xC) + sqr(yC));
  WriteLn; Write('Ответ : ');
  If
(DistA < DistB) and (DistA < DistC)
then WriteLn( 'Это точка А.')
else If
(DistB < DistC)
then WriteLn('Это точка B.')
else WriteLn('Это точка C.');
  ReadLn
END.

Другие записи

10.06.2016. Пример 1.4. Найти произведение цифр заданного целого четырехзначного числа.
Система тестов Номер теста Проверяемый  случай Число Результат 1 Число положительное 2314 P = 24 2 Число отрицательное -1245 P = 40 Школьный АЯ алг Произведение…
10.06.2016. Пример 1.5. Решить квадратное уравнение ax2 + bx + c = 0.
Система тестов Номер теста Проверяемый случай Коэффициенты Результаты a b c 1 d >0 1 1 -2 x1 = 1, x2 =  - 2 2 d=0 1 2 1 Корни равны:  x1 =  - 1, x2 =  - 1 3 d<0 2 1 2 Действительных…
10.06.2016. Пример 1.6. Две прямые описываются уравнениями a1 x + b1 y + c1 = 0; a2 x + b2 y + c2 = 0. Напечатать координаты точки пересечения этих прямых, либо сообщить, что эти прямые совпадают, не пересекаются или вовсе не cуществуют.
Система тестов Номер теста Проверяемый  случай Коэффициенты прямых Результаты a1 b1 c1 a2 b2 c2 1 Первая прямая не существует 0 0 1 1 2 2 Это не прямая 2 Вторая…