Пример 2.2. Найти наибольший элемент числового массива A = (a1, a2 , ..., aN ) и его номер.

числовой массив   A = (a1 , a2 , ... , aN ).
Тест

Данные Результаты
N=4 A=(3, -1, 10, 1) Amax=10 K=3

 

Школьный АЯ 
алг МаксЭлемент (арг цел N, арг вещ таб A[1:N],
рез вещ Amax, рез цел k)
нач цел i
  Amax := A[1]; k := 1
  нц для i от 2 до N
  если A[i] > Amax
  то Amax:=A[i]; k := i
  все
  кц
кон
Исполнение алгоритма 
 

i A[i] > Amax Amax k
2
3
4
-
+
-
3
10
 
1
3
 

 
Блок-схема 


Turbo Pascal
Program MaxElem;
  Uses Crt;
  Type Mas = Array [1..20] of Real;
  Var A   : Mas;
  i, N : Integer;
  k   : Integer;
  Amax : Real;
BEGIN
  СlrScr;
  Write('Введите N = ');
  ReadLn(N);
  For i := 1 to N do {Ввод значений элементов массива А}
  begin
  Write('A [ ', i, ' ] = '); ReadLn(A[i])
  end;

  Amax := A[1]; k:=1; {Поиск максимального элемента}
  For i := 2 to N do
  If
A[i] > Amax then
  begin
  Amax := A[i]; k := i
  end;

  WriteLn; WriteLn('Наибольший элемент' , k , '-й');
  WriteLn('Его значение ', Amax : 5 : 1);
ReadLn
END.
 
QBasic

CLS
INPUT "N = "; N : DIM A(N)
FOR i = 1 TO N ' Ввод массива А
  PRINT "A("; i; ") = ";
  INPUT A(i)
NEXT i

Amax = A(1) : k = 1   ' Поиск максимального элемента
FOR i = 2 TO N
  IF
A(i) > Amax THEN Amax = A(i) : k=i
NEXT i

PRINT "Наибольший элемент" ; k ; "-й"
PRINT "Его значение" ; Amax
END

Другие записи

10.06.2016. Пример 2.3. В баскетбольную команду могут быть приняты ученики, рост которых превышает 170 см. Составьте список кандидатов в команду из учеников класса.
Система тестов Номер  теста Проверяемый  случай Число  учеников Фамилии Рост Результаты 1 Есть  кандидаты 3 Кулов  Чехин  Уваров 171 165 178 Кулов  Уваров 2 Нет  кандидатов 2 Ершов  Иванов 170 165 Нет  кандидатов Школьный…
10.06.2016. Пример 2.4. Для заданного x вычислить S= х/1! + x2/2! + x3/3! + xn/n! Здесь n! = 1. 2. 3 .... n (читается как "n-факториал").
  Тест Данные Результат X=1 n=3 Школьный АЯ алг Сумма Ряда (арг вещ х, арг цел n, рез вещ S) нач цел i, вещ P | P - очередное слагаемое   S := 1; P := 1   нц для i…
10.06.2016. Пример 2.5. Дан массив X(N). Получить новый массив Y(N) такой, что в нем сначала идут положительные числа, затем нулевые, и затем отрицательные из X.
Тест Данные Результат N=7  X=(-1, 2, 0, 4, -3,-2,0)  Y=(2, 4, 0, 0, -1, -3, -2) Школьный АЯ алг Новый Порядок (арг цел N, арг вещ таб Х[1:N], рез вещ таб Y[1:N]) нач цел…