Графические редакторы систем автоматизированного проектирования (САПР)

1. CirCad - программа для создания радиосхем.

Вход в программу - !start.bat или circad.exe.

Выход из программы - Q и Enter.

GrafEdit - простейший чёрно-белый графический редактор

элементов *.grf.

Для входа в программу надо запустить файл gredit.exe.

Вызов меню F10. Выход из программы - нажать Q и ответить Y.

Формат файлов - *.drw, *.prt.

 

СТРОЕНИЕ ПРОГРАММЫ

Программа CIRCUIT CAD состоит из EXE-файлов CIRCAD.EXE (редак-

тор принципиальных схем в рисунках формата *.DRW), ICEDIT.EXE

(редактор микросхем *.PRT), GREDIT.EXE (редактор радиоэлементов,

фигур, картинок и букв в формате *.GRF), а также цвето-графичес-

кого драйвера CGA.BGI и установщиков шрифтов LITT.CHR, TRIP.CHR.

В этом графическом редакторе главное место занимает CIRCAD.EXE,

а файлы ICEDIT.EXE и GREDIT.EXE - утилиты. Все они двухцветны.

 

КОМАНДЫ И ПРАВИЛА РАБОТЫ В CIRCADE

Нажатие ESC или правого батона мыши вызывает главное меню со

всеми его командами и двойной структурой (большее PREVIOUS MENU и

меньшее NEXT MENU), но для вызова команд этого меню достаточно

нажимать клавиши с первыми английскими буквами этих команд. При-

водим подробный список команд:

L - LOAD DRAWING - вызвать *.DRW-файл, в появляющемся списке всех

имеющихся в данном каталоге *.DRW выбрать имя интересующего Вас

чертежа;

S - SAVE DRAWING - сохранить созданный Вами чертёж, в появляющей-

ся командной строке написать имя чертежа без расширения, расшире-

ние будет DRW;

P - PRINT DRAWING - распечатать редактируемый чертёж в мелком

масштабе (выбор ..PRINTED SMALL) или в крупном (выбор ..PRINTED

LARGE);

H - HELP - вызов справочника со всеми возможностями редактора

CIRCAD;

Q - QUIT - выход (выбор строки "QUIT & ABORT PROGRAM", можно выб-

рать и строку "RETURN TO PROGRAM" для отказа от выхода из прог-

раммы);

F6 - REDRAW BORDER - обновить редактируемый экран без потери ин-

формации;

F5 - SET SCREEN COLOR - отказаться от стандартного чёрно-белого

редактирования и выбрать любое из 15-ти (по порядку нажатий F5)

двухцветных сочетаний: голубой по любимому Вам фону (лучше всего

тёмно-синий фон);

F4 - SET SNAP TO 5 - установить ШАГ движения по экрану вставляе-

мого в чертёж элемента .GRF или микросхемы .PRT в 5 пикселей (эк-

ранных точек);

F3 - SET SNAP TO 10 - установить ШАГ в 10 пикселей (принимается

уже по умолчанию при заходе в CIRCAD);

F2 - ISSUE DOS COMMANDS - выполнять в появляющейся длинной ко-

мандной строке простейшие команды MS DOS.

F1 - TEXT PARAMETRS - выбрать шрифт LITT.CHR или TRIP.CHR и выб-

рать размеры символов (от 2 до 9) и их форму и способ расположе-

ния;

T - TEXT:-в появляющейся строке написать текст выбранным шрифтом;

E - ERASE (стирание) - установить ластик (в один символьный прямоугольник);

Нажатие правого батона мыши вызывает рисование линии.

O - ORTHOGONAL MODE - режим рисования только перпендикулярных

(вертикальных и горизонтальных) линий, при входе в CIRCAD стоит

по умолчанию;

B - BUSS LINE - рисовать жирную линию.

 

2. Программа ProtoCad предназначена для черчения трехмерных фигур.

Для входа в программу запустить файл pc3d.exe.

Имеет возможности трёхмерного стереометрического САПР-редактора и

позволяет, пусть ограниченно, создавать художественные картины, но

обладает одним недостатком: в одном чертеже не более 5200 точек

графического изображения.

Удаление объекта - меню Edit, Erase, выделить стираемый объект.

Рисование сферы - меню 3D, Sfera.

Рисование тетраэдра - меню 3D, Platonic, Tetra.

Загрузка файла - меню File, Load.

Сохранение файла - меню File, Save.

Выход из программы - меню File, Exit.

 

3. Программа MathCad 2.50 - САПР по математике.

Программа MathCad служит для вычисления функций, построения

графиков и решения уравнений.

Вход в программу - файл !start.bat (или mcad.exe).

Вызов меню - F10. Помощь - F1. Выход из программы - Ctrl+Q.

Формат файлов - *.mcd

 

4. Программа FloorPlan 2.0 - Архитектурный СтройКад.

Программа FloorPlan служит для проектирование планов жилых

помещений. Для входа в программу служит файл !start.bat.

Выход из программы - Alt-F4. Стирание: меню Edit, Select, Delete.

Формат файлов - *.pln. Возможно преобразование файла в *.3dw и

3D-просмотр (трёхмерный) с помощью 3dvga.exe.

Сохранение файла - Save as. Формат файлов - *.pln

Рисование стены - меню Element, Free Wall.

Удаление объекта - меню Edit, Select, Delete.

Поворот объекта - меню Edit, Select, Rotate, Angle (ввести угол)

Ковертирование файла name.pln в трёхмерный

образ name.3dw - Меню, Картинка с изображением очков.

Для трёхмерного просмотра выйти из FloorPlan и, оставаясь

в каталоге FLOOR, набрать в командную строку 3dvga name.3dw

Выход из просмотрщика 3dvga.exe - Q, Y (Yes).

 

5. Программа AutoCad 10 - САПР для черчения.

Программа AutoCad служит для создания чертежей различных

деталей. Вход в программу - файл !start.bat (или acad.exe).

Формат файлов - *.dwg

 

6. Программа Компас - это САПР для черчения.

Система КОМПАС предназначена для построения и выпуска чертеж-

но-конструкторской документации в соответствии с требованиями

ЕСКД, а также для создания прикладных систем САПР.

Вход в программу - файл !start.bat (или kompas.exe).

Формат файлов - *.cad

 

7. Программа PCAD 4.5 - САПР радиосхем и печатных плат.

Программа PCAD 4.5 служит для проектирование радиосхем и печат-

ных плат.

 

Состав программ PCAD и структура рабочих файлов проекта.

 

Пакет прикладных программ PCAD содержит в своем составе три гра-

фических редактора PCCAPS, PCPLACE и PCCARDS, программу PCROUTE

для автоматической трассировки соединений печатной платы с числом

слоев от 1 до 32 и программы утилиты, выполняющие служебные функ-

ции. Распечатка радиосхем и печатных плат производится с помощью

программы PCPrint. Программа PCCAPS является редактором радиос-

хем, а программа PCCARDS представляет собой редактор печатных

плат. Программа PCCAPS создаёт файлы формата sch. Программа

PCCAPDS создаёт файлы формата pcb. Программа PCPrint работает с

файлами формата plt.

Другие записи

10.06.2016. Текстовый редактор Word & Deed ("Слово и дело") для DOS.
Текстовый редактор Word & Deed (версия 7.20) имеет русскоязыч- ный интерфейс и справочную систему. Автор W&D - А. Гутников. Предназначен для создания и редактирования текстовых файлов с использованием…
10.06.2016. Средства мультимедиа
Мультимедиа - это технология, объединяющая информацию (данные), звук, анимацию и графические изображения. Кроме того, мультимедиа - это средства обмена информацией между компьютером и внешней средой.…
10.06.2016. Средства коммуникаций и мировые компьютерные сети. Интернет. Электронная почта. Локальные сети персональных компьютеров.
Средства коммуникаций и мировые компьютерные сети. Интернет. Электронная почта. Локальные сети персональных компьютеров.   Крупнейшей глобальной информационной системой является сеть Ин- тернет,…
10.06.2016. DOS Navigator, Windows Commander и другие программные оболочки.
DOS Navigator DOS Navigator представляет собой программную оболочку для работы с DOS. Относится к семейству нортонообразных оболочек. Его версия 1.50 очень похожа по интерфейсу и функциональным…
10.06.2016. Операционная система Windows-95
План урока   1. Основные понятия. Запуск Windows-95. Выход из Windows-95. 2. Версии Windows-95. 3. Преимущества и недостатки Windows-95. 4. Требования к компьютеру для установки Windows-95. 5.…