Интегрированная среда MS Works 3.0.

  •  
      Пакет программ MicroSoft Works представляет собой интегрированную среду, включающую в себя текстовый процессор, электронные таблицы, систему управления базами данных и средство коммуникаций (систему компьютерной связи). Таким образом, все основные офисные компьютерные технологии в Works удачно объединены в одном пакете, что очень удобно для пользователя. Между составными частями пакета MS Works возможен обмен информацией, что также очень важно. Дистрибутив программы MS Works 3.0 очень невелик - это всего 4 дискеты по 1,44 Мб или около 5,5 Мб, что весьма удобно.

      Пакет программ MS Works имеет следующие версии: MS Works 2.0 для DOS (для старых машин 286 и 386SX), MS Works 3.0 для Windows 3.1 и MS Works 4.0 и 4.5 для Windows 95. Мы рассмотрим только MS Works 3.0.

      Текстовый процессор MS Works 3.0 по своим возможностям и интерфейсу очень похож и во многом аналогичен Word 2.0 или WordPad.

      Электронные таблицы MS Works 3.0 аналогичны и очень похожи по своим функциям на Excel 4.0. Поэтому мы рассмотрим подробно только систему управления базами данных.

      Для запуска MS Works 3.0 надо запустить Windows 95, найти в меню кнопки Пуск или на рабочем столе значок MS Works 3.0 и дважды щелкнуть по нему мышью. Для старого Windows 3.1 надо найти программную группу MS Works 3.0 или MS Office, найти программный элемент MS Works 3.0 и нажать Enter.

      Создание, сохранение и загрузка файла в MS Works 3.0 производится также, как и в Word или Excel.

      Выход из MS Works- Alt+F4, если в окне сохраненный файл. В противном случае файл надо сперва сохранить или выходить без сохранения.

      MS Works 3.0 имеет справочную систему и демонстрационную обучающую программу, что особенно удобно для начинающих пользователей. Запуск обучающей программы Shift-F1.


      Краткий обзор баз данных MS Works 3.0
      Базы данных Works используются для создания, обработки и хранения списков клиентов, товаров и прочей информации. Они очень удобны для создания баз данных в виде формы школьного социолога, психолога, врача, классного руководителя, завуча. При их помощи возможна разработка ученических проектов, например, на темы: "Агент по кадрам", "Агент по недвижимости" и др. Базы данных Works намного проще баз данных Access, что важно при использовании в учебных целях. Информация в базе данных упорядочена по записям и полям. Запись - это вся информация о клиенте, товаре, событии и т.п. Отдельный самостоятельный элемент записи (например, фамилия или адрес) называется полем. Поля могут содержать текст, числа, даты или формулы. Каждая запись базы данных содержит один и тот же набор полей.

      База данных может содержать до 32000 записей; каждая запись может содержать до 256 полей.


      Существуют два режима работы с базой данных:
      В режиме формы пользователь работает одновременно с одной записью, для изображения которой используется разработанная им форма, например, бланк заказа. Переключение из режима формы в режим таблицы и обратно - F9.

      В режиме таблицы пользователь работает одновременно с несколькими записями, представленными в виде таблицы.

      Кроме того, пользователь может использовать режим запроса (для извлечения информации из базы данных) и режим описания отчета (для группирования информации).

      При создании новой базы данных для ее изображения используется режим формы. Пользователь разрабатывает форму, а затем вводит информацию в базу данных по одной записи за раз. Более подробную информацию о работе с базами данных можно получить из обучающей программы, входящей в состав Microsoft Works 3.0 для Windows.

      Для того чтобы переключиться в другой режим базы данных, выберите Форма, Таблица, Запрос или Отчет в меню Вид.

      Примечание: После выбора команды Запрос или Отчет в меню Вид, на экране появляется окно диалога, в котором следует выбрать нужный запрос или отчет.


      Создание базы данных в режиме формы

      Интерфейс баз данных MS Works в виде формы


      Для того, чтобы создать базу данных в режиме формы, необходимо запустить MS Works 3.0, нажать кнопку БАЗА ДАННЫХ или выбрать СОЗДАТЬ НОВЫЙ в меню ФАЙЛ, а затем нажать кнопку БАЗА ДАННЫХ. На экране появится пустая форма в режиме формы.
      Для того, чтобы создать поле, необходимо:
      1. Установите курсор мыши в то место, где должно начинаться поле, и нажмите левую кнопку мыши.

      2. Введите имя поля (не более 15 символов), а затем ДВОЕТОЧИЕ, или Меню Поместить, Поле. Пример: Новое имя:

      Примечание: ДВОЕТОЧИЕ указывает, что вводится имя поля, а не подпись. Имя поле не может начинаться с одной или двух кавычек или апострофа. По мере ввода символов они отображаются в форме и в области редактирования.

      3. Нажмите Enter. На экране появится окно диалога Размер Поля. Затем либо примите стандартные ширину и высоту поля, либо измените предложенные значения.

      4. Нажмите кнопку ОК. MS Works 3.0 создаст поле указанной ширины и высоты и разместит его справа от имени поля. Это поле будет изображаться в форме для каждой записи.

      Для того, чтобы ввести в поле текст, число или дату, необходимо:

      1. Выделите поле, в которое следует ввести информацию.

      2. Введите нужное значение: текст, число, дату или формулу.

      Вводимые символы отображаются в поле и в области редактирования.

      3. Нажмите Enter.

      Для того, чтобы разместить подпись к базе данных, необходимо:

      1. Установите курсор мыши в то место, где должна начинаться подпись, и нажмите левую кнопку мыши или Меню Поместить, Подпись.

      2. Введите текст подписи.

      Примечание: Не вводите Двоеточия, иначе WORKS решит, что вводится имя поля. Если вы всё же хотите включить Двоеточие в подпись, то введите в начале подписи двойную кавычку. Пример: "введите Ваше имя:.

      3. Нажмите Enter.

      Для того, чтобы изменить положение поля или подписи, необходимо:

      указать на это поле или подпись мышью и с помощью мыши перетащить его на новое место. В результате надо создать и сохранить файл, который получит расширение *.wdb.

      Чтобы переключиться из режима Форма в режим Таблица для базы данных, необходимо после запуска Works и нажатия кнопки База Данных в меню Вид выбрать пункт Таблица или нажать F9.


      Создание базы данных в режиме Таблицы

      Интерфейс баз данных MS Works в виде таблицы


      Каждая строка таблицы является записью, а каждый столбец - полем.

      Для создания поля следует присвоить имя пустому полю.

      Для того, чтобы создать базу данных в режиме Таблицы, необходимо:

      После запуска WORKS нажать кнопку База Данных или выбрать СОЗДАТЬ НОВЫЙ в меню Файл, а затем нажать кнопку База Данных. На экране появится пустая форма в режиме Формы. Для того, чтобы переключиться в режим таблицы, нажмите кнопку "Таблица" на панель инструментов. На экране появится пустая таблица в режиме таблицы.

      Для того, чтобы создать поле путём ввода информации, необходимо:

      1. Выделить пустое поле, в которое следует ввести информацию.

      2. Ввести нужное значение: текст, число, дату или формулу.

      Вводимые символы отображаются в поле и в области редактирования.

      3. Нажмите Enter.

      В режиме Таблицы WORKS автоматически присваивает имена безымянным полям, например: Поле1, Поле2 и т.д.

      Для того, чтобы изменить имя поля, необходимо:

      1. Выделить поле, имя которого следует изменить.

      2. Выбрать Имя Поля в меню Правка.

      3. В строку ввода "Имя" ввести уникальное имя поля (не более 15 символов). Пример: Новое имя.

      Примечание: Имя поле не может начинаться с одной или двух кавычек или апострофа.

      4. Нажать кнопку ОК. Новое имя изображается как заголовок поля.

      В результате надо создать и сохранить файл, который получит расширение *.wdb.


      Создание базы данных с помощью Шаблонов и Мастеров
      Для создания стандартных базы данных можно использовать Шаблоны или Мастера. Например, если создается Адресная книга или Опись имущества, или Простая база данных. Это значительно упрощает процесс создания базы данных и её оформление. Для этого после запуска Works надо выбрать кнопку Шаблоны или Мастера, а затем выбрать из предложенного Вам списка необходимый пункт. Далее надо отвечать Да на все запросы и база данных (пустая) будет создана. Теперь надо только её заполнить и сохранить в виде файла.
      Поиск информации в базе данных
      WORKS позволяет быстро выполнить поиск информации в базе данных.

      Если база данных имеет вид формы, то следует указать, искать ли информацию во всей базе данных или только в выделенных полях.

      Для того, чтобы перейти к конкретному полю текущей записи, необходимо:

      1. Выбрать пункт ПЕРЕЙТИ в меню Правка (или F5).

      2. В строку ввода "Имя" ввести имя поля, которое следует выделить, или из списка "Имена" выбрать имя поля, которое следует выделить.

      3. Нажать кнопку ОК. Указанное поле будет выделено.


      Поиск информации в базе данных в режиме Таблицы
      1. В режиме таблице выделите одно или несколько полей, в которых следует выполнить поиск. Если нужно выполнить поиск во всей базе данных, выделите только одно значение поля.

      2. Выбрать подпункт НАЙТИ в меню Правка.

      3. В строку ввода "Образец" введите искомую информацию.

      4. Для того, чтобы перейти к следующему значению поля, которое содержит искомую информацию, надо выбрать параметр "Следующую", или, для того, чтобы обработать все записи, в том числе невидимые, надо выбрать параметр "Все Записи".

      5. Нажмите кнопку ОК. Если текущим является режим Таблицы, и поиск завершился успешно, то WORKS покажет все найденные записи, если выбран параметр "Все Записи". Если текущим является режим Формы, и поиск информации завершился успешно, то WORKS покажет только первую найденную запись.

      Чтобы перейти к следующей записи, если она существует, надо нажать F7.

      Для того, чтобы снова показать все записи, надо выбрать пункт "Показать Все Записи" в меню Вид.


      Вставка объектов в базу данных Works в режиме формы
      Вставка объектов производится по месту положения курсора.

      Для вставки объектов в базу данных необходимо указать мышью пункт Меню Поместить, затем выбрать:

      1) подпункт Иллюстрация, если надо поместить рисунок из библиотеки Clipart;

      2) подпункт Рисунок, если надо создать и вставить рисунок MS Draw.

      3) подпункт Объект, MS WordArt, если надо поместить текстовые спецэффекты, редактор формул Equation Editor, если надо поместить формулу, редактор диаграмм MS Graph, если надо поместить диаграмму.

      4) Для помещения документов Word и Excel в базу данных Works надо тоже использовать пункт меню Объект и выбрать соответствующий пункт. Для внедрения объектов в базу данных Works можно также использовать Буфер Обмена Windows (Меню Правка, Специальная вставка).


      Защита информации в базе данных Works
      Для защиты формы в базе данных Works в режиме формы надо указать пункт меню Формат, Защита, установить флажок "Защита формы". Для защиты данных устанавливают флажок "Защита данных".
      Краткий обзор электронных таблиц MS Works 3.0
      Электронная таблица - это компонент MS Works, предназначенный для выполнения финансовых, статистических и прочих вычислений и хранения информации. После того как в строки и столбцы электронной таблицы будет введена информация, можно: Добавить формулы, предназначенные для выполнения вычислений. При составлении формул можно использовать 76 функций, анализировать информацию, представляя ее в графическом виде, изменить оформление электронной таблицы: шрифты, числовые форматы и т.п. Можно включить отдельные области электронной таблицы и диаграммы в документы текстового процессора. Создание электронной таблицы начинается с ввода информации в ячейки. (Ячейка - это прямоугольник, который лежит на пересечении строки и столбца.) В ячейки можно вводить текст, числа, даты и время. Для того чтобы выполнить вычисления над строкой или столбцом чисел, следует ввести формулу. Если после того, как формула будет введена, изменится содержимое ячеек, на которые ссылается эта формула, то значение формулы будет автоматически обновлено.
      Краткий обзор системы связи MS Works 3.0
      С помощью системы связи MS Works можно подключиться к другому компьютеру и обмениваться с ним информацией. Например, таким образом можно получить свежую информацию о биржевых ценах, сделать покупку и обмениваться файлами с пользователями других компьютеров. Для того чтобы система связи Works могла участвовать в обмене информацией по телефонной сети, необходимо, чтобы на вашем компьютере был установлен внутренний или внешний модем. Кроме того, можно обмениваться информацией, соединив два компьютера напрямую с помощью кабеля. Первый сеанс связи с другим компьютером состоит из следующих этапов:

      Создание файла системы связи

      Настройка параметров

      Подключение (установка связи)

      Обмен информацией

      Отключение

      После первого сеанса связи с конкретным компьютером можно сохранить текущие значения всех параметров в виде файла системы связи. Имя этого компьютера появится в меню Телефон. Когда вам в следующий раз понадобится установить связь с этим компьютером, выберите его в меню Телефон и Works автоматически выполнит процедуру подключения.

Другие записи

10.06.2016. Список использованных учебных компьютерных программ
1. Обучающая программа "ПРОФЕССОР". Атлант-Информ, 1993. 2. Обучающая программа "Инструктор 2.20". Дж. Хэндриксон, 1991. 3. Автоматизированный справочник по Norton Commander. НУЦ НПО ВТИ, Казань,…