СПРАВОЧНЫЕ МАТЕРИАЛЫ: Команды алгоритмического языка

 

Команды Примеры
а) оператор ввода
ввод имена величин ввод N, К, РР
б) оператор вывода
вывод тексты, имена величин, выражения вывод N, К, РР
в) оператор присваивания
имя величины := выражение k := 1
г) оператор вызова
имя алгоритма (аргументы и имена результатов) точка(10,20)
д) утверждение
утв условие утв k > 0
е) "цикл"
нц число повторений раз тело цикла (последовательность команд)
кц
цикл 11 раз
k := k 2
п := п / 2
кц
нц пока условие тело цикла (последовательность команд)
кц
    цикл пока к > 0
    k := k - 1
    m := m + 1
кц
    нц для i от i1 до i2 тело цикла (последовательность команд)
    кц
цикл для N от 1 до 5
k := k / 2
i := i 2
кц
ж) "если"
если условие то серия 1 иначе серия 2 все если k > 0
то m := k иначе m := -k
все
если условие
то, серия 1все
если k < 0
то k := -k
все
з) выбор
    выбор
    при условие 1 : серия 1 при условие 2 : серия 2
    при условие п : серия п
    иначе серия п+1
    все
Выбор
при k < 0 : k := -1
при k == 0 : k :== 0
при k < 50 : k := k 2
при k < 100 : k := k 3
иначе k := 1000
все
    Выбор
    при условие 1 : серия 1
    при условие 2 : серия 2
    при условие n : серия n
    все
выбор
при k/5 =0: n := 1
при k/5 = 1: n := 2
при k/5 =2: n := 1
при k/5 =3: n := 2
все